lunes, 1 de febrero de 2016

Wake On Lan con Macs corriendo Windows vía Bootcamp

Tengo un cliente con cinco Macs en sus instalaciones. Dos son Mac Minis, y el resto son iMacs. En total tienen unos 90 PCs y suelo activarlos remotamente para efectuar mantenimiento... menos los Macs.

He estado buscando, rebuscando y más para ver porqué si envío paquetes de activación no hay manera de que se enciendan. Al final, después de mucho rebuscar he encontrado la respuesta: los dichosos Macs funcionan todos con un Windows 7 corriendo sobre Bootcamp. Apple tiene publicados drivers específicos para Windows de sus máquinas, pero lo que viene a ser el WOL no lo tienen bien implementado. En un Mac corriendo OSX como toca, no hay problema para arrancarlo.

Pero hay una solución, y es activar el aparato vía USB. Eso implica un adaptador de red vía USB, con lo que activará la máquina si le enviamos un paquete WOL.

La información detallada viene en este artículo (en inglés):

https://wilfredomaldonado.wordpress.com/2015/03/12/boot-camp-mac-mini-s3s4-wol-solution/


A mí no me soluciona nada, pero puede que a algún visitante sí.


jueves, 12 de marzo de 2015

Reproducción de vídeo y tearing


Hace ya tiempo me mosqueé con mi PC. Tenía un problema reproduciendo vídeo, aparece una raya horizontal partiendo un poco la imagen, dejando la imagen sin sincronizar del todo. Lo que en inglés se llama tearing y suele ser arreglado empleando la sincronización vertical o vsync.

Sin embargo, no encontré remedio. Uso una  nvidia gForce GT 520 y a pesar de que no debería fallar, fallaba. No importaba el reproductor o el códec empleado, ni las peleas con la configuración del driver o del reproductor. Viendo películas había ese fallo. Sobre todo se nota mucho en escenas de acción o si la cámara gira.

Hoy, de casualidad, buscando otra cosa y gracias a un forum de esos que pulula, me encontré a alguien con un problema similar en su portátil. Y a alguien que se lo resolvió con una solución extraña: si empleas windows 7, activa el aero.

Efectivamente, señores, como soy minimalista, tenía el tema mas simple y clásico de windows 7... sin aero. Al activar otro tema de windows, con sus transparencias aero, el driver automáticamente activó la opción de vsync adaptativo para 2D, cosa que no puede hacerse desde el panel de control del controlador nvidia.

Desde hoy, ya veo las películas como toca.

sábado, 7 de marzo de 2015

Va de virus


Pues delante de mí tengo un PC. Razonablemente moderno, aunque con Windows XP por motivos de un software algo obsoleto que se necesita emplear. Lleva un NOD32 antivirus business, que misteriosamente ha dejado de funcionar. No hay síntomas adicionales de algo raro. Ni ralentización, ni páginas raras apareciendo, ni aparentemente procesos extraños.

Primera opción: vamos a reinstalarle en antivirus... no se deja! Da error!

Entonces vamos a ver si en la maquinita hay bicho. Ups! Al intentar el ejecutar el Malwarebytes, que también estaba instalado en esa máquina, no arranca. Esto huele mal.

Segunda opción: voy a arrancar desde un USB con el Kaspersky Rescue 10. Paso un escaneo completo pero no ha encontrado nada.

Veamos... ¿y si ha sido algún problema de windows? ¿O del mismo antivirus?

Tercera opción: vamos a instalarle un antivirus diferente... tampoco se deja instalar!

A estas alturas el mosqueo es grande: es obvio que hay algo, pero las herramientas habituales no detectan nada. ¿Será un rootkit? Al parecer el Kaspersky no controla eso.

Cuarta opción: arrancar desde un USB con el Dr.Web CureIt, pero antes de iniciar el escaneo le habilito la búsqueda de rootkits, de sectores de arranque, etc...

Bingo! Cidox, parece que se llama el bicho y está en el MBR! Limpieza, reinicio y ya podemos instalar el antivirus sin problema.

Aquí podéis descargar el software maravilloso:

Dr.Web Live CD/USB


martes, 17 de febrero de 2015

Mi Android no sale en la lista de dispositivos de Google Play

Si te ha desaparecido un dispositivo android de la lista en Google Play:
  • Ves a Ajustes -> Aplicaciones y borra los datos de las siguientes applicaciones: 

  1. - Google Play Store
  2. - Descargas
  3. - Marco de Servicios de Google

  • Reinicia tu móvil.
  • Inicia la app de Google Play Store
  • Abre el Play Store en tu navegador del PC y espera a que tu dispositivo aparezca. Puede tardar en aparecer (incluso horas). Aparecerá en Ajustes -> Administrador de Dispositivos
  • Una vez aparezca el dispositivo en la web Y NO ANTES, haz lo siguiente:
  1. Abre Ajustes de Google en tu dispositivo.
  2. Selecciona Administrador de Dispositivos o Seguridad (según el aparato)
  3. Desmarca "Permitir borrado y bloqueo remotos"
  • Ves a Ajustes -> Aplicaciones -> Servicios de Google Play
  • Selecciona "Borrar datos"
  • Vuelve a Ajustes de Google y vuelve a marcar la opción que antes desmarcaste.
  • Reinicia tu dispositivo.

Listo!

domingo, 1 de febrero de 2015

Bloqueos de pantalla del THL W300


Puede que a alguno de vosotros le ocurra lo mismo que me ha estado ocurriendo a mí.

Cada vez que la señal cambiaba de 3G a GSM en alguna de las tarjetas, se bloqueaba el móvil. Tocaba darle al patrón de desbloqueo. Si estaba en una zona con cobertura regular, se convertía en un calvario. Si bien se reducía cuando en la configuración forzabas al móvil a trabajar sólo en 3G, seguía fallando.

Por fin he encontrado la solución definitiva (en inglés). Requiere algo de trabajo manual, pero vale la pena:

http://forum.xda-developers.com/showthread.php?p=56369233#post56369233

Espero que os sea útil.


viernes, 13 de junio de 2014

Pues sí que llevo tiempo sin publicar...


En fin, es lo que tiene casarse (otra vez) y tener 2 trabajos...
Sigo en la brecha y rompiéndome los cuernos con lusers.

Por cierto... ¿alguien sabe cómo se consigue meter un virus en un iPad?
Dicen que me van a traer uno virificado. Las manzanas sin cuidar al final se pudren ;)

lunes, 23 de noviembre de 2009

Pequeño cambio en el blog.

Por lo visto, los malos malosos spambots han tomado al asalto la blogosfera, y empiezan a proliferar los mensajes que apuntan a webs malignas, por lo que tengo que activar la validación de los comentarios que se hagan.

Próximamente se volverá a postear en este blog, después de múltiples vicisitudes. Ya os contaré ;)